Расширение для Firefox перестало работать, требуется минимальная версия браузера 91.0.0

  • Тип настройки: браузерное расширение
  • Тип проблемы: не работают все заблокированные сайты
  • Что с сайтом: ошибка в браузере
  • Используемый браузер: Waterfox G3.2.3 (64-bit)

Описание проблемы

Расширение для Firefox перестало работать, требуется минимальная версия браузера 91.0.0 (информация с Addons Mozilla, все версии расширения теперь имеют это требование). Это намеренное решение создателей расширения, теперь им нельзя пользоваться в более старых браузерах?

Как-то давно расширение проверялось компанией Mozilla, и они попросили всех разработчиков для ускорения процесса поднять требование к минимальной версии FireFox до 91.1.0:

"browser_specific_settings": {
  "gecko": {
    "strict_min_version": "91.1.0"
  }
},

Я не хочу изменять это требование, т.к. могу застрять на проверке на несколько недель.

Благодарю за информацию. Благодаря этому и другому совету, я смог отредактировать минимальное требование в manifest.json на этом и ещё одном расширении и дополнения заработали.

И благодарю за ваше расширение.

This post was flagged by the community and is temporarily hidden.

В чем проблема опубликовать на GitHub в обход Addons.mozilla.org специальную версию расширения “Обход блокировок Рунета”, совместимую с браузером Firefox начиная с 48-й версии (включая браузер Serpent 52 от roytam1)? Как владелец мессенджера Telegram Павел Дуров опубликовал на своем официальном сайте в обход Google Play специальную Android-версию мессенджера Telegram без ограничений на пиратские Telegram-каналы.

Проблема в том, что где бы ни выкладывалось расширение, его все равно должна проверить Mozilla. Можно выложить неподписанное расширение, но его принимают только ESR версии Firefox (после изменения about:config, с жуткой руганью, вроде), линуксовые сборки (в репозитории дистрибутивов) и Unbranded. Может, Nightly.

Есть ли резон портировать расширение “Обход блокировок Рунета” на браузеры Pale Moon, Basilisk и их совместимые с Windows XP/Vista форки (Mypal 29.3.0 и Centaury 0.17.0 от Feodor2, Serpent 52/55 и New Moon 27.10.0/28.10.6a1 от roytam1)?

Моложе, чем версия FireFox 60 не выйдет, т.к. нужный API только там: см. Поддержка Firefox 60+ · Issue #18 · anticensority/runet-censorship-bypass · GitHub.